A Apple inclui nativamente o PHP 7.3 nessa versão do macOS mas, por exemplo, sem a extensão php-zip.

Isso impossibilita a instalação de uma série de componentes via composer.

É possível remover os binários do php 7.3 mas eles retornaram na próxima atualização do sistema operacional.

Uma solução é instalar outra versão do PHP via brew e indicar que ela é a padrão para uso do sistema via export como segue abaixo:

brew install php@7.4

adicionar as seguintes linhas ao ~/.bashrc:

export PATH=”/usr/local/opt/php@7.4/bin:$PATH”
export PATH=”/usr/local/opt/php@7.4/sbin:$PATH”

Profit!